Search This Blog

Thursday, 27 December 2012

Raspberry Pi & Samba 4

An early Christmas present to myself in the form of a Raspberry PI, no specific plans for it but just wanted one.

I forgot to order a SD card with the OS installed but the wiki instructions and a 16GB card I used in my DSLR worked fine, up and running in less time than it took to download the .img file.

OS is Debian based and the repository is pretty up to date.  I'd recently read that Samba4 was now a full MS AD viable replacement and I fancied a crack at replacing the core services on my home network, currently fulfilled by my NAS.  Rumblings of a web authentication project at work which MS AD is being touted as the directory of choice (yes really) also gave me a good reason.

Install went fine, the rest not so.  Samba 4 requires DNS & Kerberos as partners in crime.  The Wiki was source code centric and alluded to an internal DNS service.  The repo build included BIND 9, which it took me ages to work out, but not Kerberos, which required an separate install.  Needless to say they didn't want to play nicely.

All in all after a few days playing I threw in the towel.  I've no doubt with some perseverance and cursing I could have got it working but figured that I don't really want something that complex running my house core.  One upgrade and pop, back to square one.

But I do like the PI

Monday, 10 December 2012

Cleaning up BackTrack/Ubuntu NIC's

Copying BackTrack virtual box images around and the network wouldn't start.  I'm Recording the commands here as its not something I do everyday and I will have the same issue again .. Same process would work for Ubuntu.

[email protected]:~# ifconfig eth0 up
eth0: ERROR while getting interface flags: No such device

[email protected]:~# lspci
Will list all the hardware devices.  Confirm the Ethernet controller is loaded.

[email protected]:~# ifconfig -a
Will list all the interfaces known to the system regardless if they are 'UP'.  In my case the card was ETH4.

[email protected]:~# ifconfig eth4 up
Worked.

I wanted to clean this up as ETH0-3 are all a result of switching machines and MAC address.

nano /etc/udev/rules.d/70-persistent-net.rules

remove the redundant config and switch your NIC to ETH0